課題

プロジェクトをTomcatで実行しようとしたらエラーメッセージが発生

「プロジェクト・ファセット Java バージョン 11 はサポートされません」

 

Tomcatで指定したJREのバージョンを確認する

このエラーは、Tomcatで指定したJREのバージョンが、プロジェクトのJREのバージョンと合致していないことが原因で発生しています。

つまり動作環境とサーバ環境のバージョンが不一致ということです。

ではエラーを解消していきましょう。

  1. [ウィンドウ]→[設定]→[サーバー]→[ランタイム環境]
  2. ここから使用したいTomcatを選択して[編集]を選択
  3. JREの欄をプロジェクトのJREと一致させます
  4. [完了]を選択して終了
  5. [プロジェクト]→[クリーン]を選択

 

これで解決されるだろうと思います。

それでも解決しない・実行されないという場合

こちらの記事も参考にしてください

https://senobi.org/eclipse-jre-compliance-level/